Platform access instability

Incident Report for HEFLO

Postmortem

Summary

On July 16, 2026, the HEFLO platform experienced a period of instability during which some users were unable to access the application. The disruption was caused by a failure in a component of our cloud provider's content delivery infrastructure (AWS CloudFront VPC Origins). We restored service the same day by routing traffic through an alternate path, and have since implemented a redundant architecture to prevent a recurrence.

Impact

During the incident window, affected users encountered errors (including HTTP 504 Gateway Timeout) when accessing the platform. The issue affected multiple regions simultaneously. Service was fully restored on the same day.

Root cause

The disruption originated from a failure in AWS CloudFront VPC Origins, the mechanism that allowed CloudFront to reach our application over a private, non-public connection. This is a provider-side infrastructure component; the failure was not caused by a change on our side. Because the affected component sits in front of all applications, the impact was broad rather than isolated to a single service.

Resolution

Our team established an alternate delivery path that bypassed the affected component, restoring access the same day. We then validated end-to-end functionality across regions before closing the incident.

What we've done to prevent recurrence

Over the following days we implemented a redundant delivery architecture. Traffic now has an automatic failover path: if the primary route becomes unavailable, requests are automatically redirected to a secondary path with no manual intervention required. This significantly reduces the time to recover from any similar provider-side disruption in the future.

We appreciate your patience and understanding during this incident.

Posted Jul 20, 2026 - 17:30 GMT-03:00

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 08:26 GMT-03:00

Update

Resolved — Incident closed
All HEFLO platform services are operational. The instability was caused by a failure in an AWS infrastructure component (CloudFront VPC Origins), now resolved by the provider. We'll continue monitoring over the next few hours. Thank you for your patience.
Posted Jul 16, 2026 - 08:26 GMT-03:00

Update

Now we are applying the same configuration for clientes with custom urls.
Posted Jul 16, 2026 - 08:14 GMT-03:00

Update

HEFLO platform services have been restored and the product is operational. The instability originated from a failure in a cloud provider (AWS) infrastructure component, for which a permanent fix is still in progress on their side. We applied an alternate route to restore access and continue to monitor. Thank you for your patience.
Posted Jul 16, 2026 - 08:10 GMT-03:00

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2026 - 08:07 GMT-03:00

Update

Europe connectivity is back with our workaround.
Posted Jul 16, 2026 - 08:04 GMT-03:00

Update

We are working on a workaround for the connectivity issue on the provider.
Posted Jul 16, 2026 - 07:20 GMT-03:00

Update

Message from the provider:
Increased 5xx Errors
jul 16 1:44 AM PDT We are investigating increased 5xx errors for Cloudfront customers utilizing VPC Origins connectivity.
Posted Jul 16, 2026 - 05:58 GMT-03:00

Investigating

We're aware that the HEFLO platform is currently unavailable for some users. Our team is investigating and has identified signs of a connectivity issue. We're working to restore service as quickly as possible and will post further updates shortly. Thank you for your patience.
Posted Jul 16, 2026 - 05:38 GMT-03:00
This incident affected: Login/SSO and HEFLO BPM (BPMN Editor - North America, Europe, Africa, Asia, and Oceania, BPMN Editor - South America).